diff debian/rules @ 215:967ecb541df9

Updated to improve the date + time handling of files. Added manpage for chronicle-spooler
author Steve Kemp <steve@steve.org.uk>
date Tue, 15 Apr 2008 20:42:34 +0100
parents e98a077a1b8b
children 076101bc0567
line wrap: on
line diff
--- a/debian/rules	Mon Apr 14 19:20:44 2008 +0100
+++ b/debian/rules	Tue Apr 15 20:42:34 2008 +0100
@@ -13,14 +13,15 @@
 
 build-stamp:
 	dh_testdir
-	pod2man bin/chronicle > chronicle.1
+	pod2man bin/chronicle         > chronicle.1
+	pod2man bin/chronicle-spooler > chronicle-spooler.1
 	touch $@
 
 clean:
 	dh_testdir
 	dh_testroot
 	rm -f build-stamp configure-stamp
-	rm -f chronicle.1
+	rm -f chronicle.1 chronicle-spooler.1
 	dh_clean
 
 install: build
@@ -32,6 +33,8 @@
 	$(MAKE) prefix=$(CURDIR)/debian/chronicle install
 	mv $(CURDIR)/debian/chronicle/usr/local/bin/chronicle \
 		$(CURDIR)/debian/chronicle/usr/bin
+	mv $(CURDIR)/debian/chronicle/usr/local/bin/chronicle-spooler \
+		$(CURDIR)/debian/chronicle/usr/bin
 	rmdir $(CURDIR)/debian/chronicle/usr/local/bin/
 	rmdir $(CURDIR)/debian/chronicle/usr/local
 
@@ -42,7 +45,7 @@
 	dh_testroot
 	dh_installchangelogs
 	dh_installdocs
-	dh_installman chronicle.1
+	dh_installman chronicle.1 chronicle-spooler.1
 	dh_compress
 	dh_fixperms
 	dh_perl